2015:abuledu_client_15.08:pourquoi_il_ne_faut_pas_melanger_des_versions_clientes_d_abuledu

Pourquoi il ne faut pas mélanger des postes clients 11.08 et 15.08 sur un même réseau

La raison est assez simple:

  • soit un utilisateur toto qui ouvre sa session sur un ordinateur abuledu 11.08 et lance firefox : ses fichiers de configuration sont donc créés avec la version de firefox qui existe sur abuledu 11.08 (disons, firefox 20)
  • ensuite toto ferme sa session et s'authentifie ensuite sur un autre ordinateur, lequel est équipé de la version abuledu 15.08, il lance alors (entre autres) firefox (qui est en version 41 actuellement sur cette version d'abuledu) … et ses fichiers de configuration de firefox sont donc “mis à niveau” pour cette nouvelle version, à priori tout marche bien
  • le problème se pose si toto retourne ensuite sur un ordinateur équipé de la version 11.08 … il y a très peu de chance pour que firefox 20 “comprenne” le contenu des fichiers de configuration de firefox 41 …
  • et c'est pareil pour tous les logiciels (libreoffice, inkscape, gimp, thunderbird, etc.)

Il ne faut donc pas jouer avec deux versions différentes du client AbulÉdu : soit un parc 100% en version 11.08, soit un parc 100% en version 15.08.

Les plus futés d'entre vous pourraient être tentés de dire “bof, pas grave, moi mon toto ne se connecte toujours QUE sur le poste-12, je peux donc mettre à jour le poste 12” … vous ne viendrez pas pleurer le jour où ça ne marchera pas, je vous aurais prévenu :)
  • 2015/abuledu_client_15.08/pourquoi_il_ne_faut_pas_melanger_des_versions_clientes_d_abuledu.txt
  • Dernière modification: 2016/07/14 14:35
  • de jean